Wednesday, February 17, 2016

ELSA-2016-0175 Critical: Oracle Linux 6 glibc security and bug fix update

Oracle Linux Security Advisory ELSA-2016-0175 http://linux.oracle.com/errata/ELSA-2016-0175.html

The following updated rpms for Oracle Linux 6 have been uploaded to the Unbreakable Linux Network:


  • i386: glibc-2.12-1.166.el6_7.7.i686.rpm
  • i386: glibc-common-2.12-1.166.el6_7.7.i686.rpm
  • i386: glibc-devel-2.12-1.166.el6_7.7.i686.rpm
  • i386: glibc-headers-2.12-1.166.el6_7.7.i686.rpm
  • i386: glibc-static-2.12-1.166.el6_7.7.i686.rpm
  • i386: glibc-utils-2.12-1.166.el6_7.7.i686.rpm
  • i386: nscd-2.12-1.166.el6_7.7.i686.rpm
  • x86_64: glibc-2.12-1.166.el6_7.7.i686.rpm
  • x86_64: glibc-2.12-1.166.el6_7.7.x86_64.rpm
  • x86_64: glibc-common-2.12-1.166.el6_7.7.x86_64.rpm
  • x86_64: glibc-devel-2.12-1.166.el6_7.7.i686.rpm
  • x86_64: glibc-devel-2.12-1.166.el6_7.7.x86_64.rpm
  • x86_64: glibc-headers-2.12-1.166.el6_7.7.x86_64.rpm
  • x86_64: glibc-static-2.12-1.166.el6_7.7.i686.rpm
  • x86_64: glibc-static-2.12-1.166.el6_7.7.x86_64.rpm
  • x86_64: glibc-utils-2.12-1.166.el6_7.7.x86_64.rpm
  • x86_64: nscd-2.12-1.166.el6_7.7.x86_64.rpm
  • SRPMS: http://oss.oracle.com/ol6/SRPMS-updates/glibc-2.12-1.166.el6_7.7.src.rpm




Description of changes:

  • [2.12-1.166.7] Update fix for CVE-2015-7547 (#1296028).
  • [2.12-1.166.6]Create helper threads with enough stack for POSIX AIO and timers (#1301625).
  • [2.12-1.166.5]Fix CVE-2015-7547: getaddrinfo() stack-based buffer overflow (#1296028).
  • [2.12-1.166.4]Support loading more libraries with static TLS (#1291270).
Post a Comment